Can't get enough amperage with P&H injectors

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't get enough amperage with P&H injectors

original posts
No matter what ai adjust in terms of peak and hold target currents, shape factors, or using adaptive injector control or not, I cannot get more that 2amp peak and .5 amp hold. Car is missing a lot also. The injectors are bosch 803 dark greens in a YB cosworth. They measure 2.5ohm. I have also tried some 0.5 amp units and the PE3 shuts down with over current faults. Anyone got any ideas as to why I can not get a clean 4/1amp pattern on my injectors?
Reply | Threaded
Open this post in threaded view
|

Re: Can't get enough amperage with P&H injectors

original posts
Think I have it sorted. Turns out the bosch dark green cosworth injectors are 4.5ohm, which explain why I could only get around 2amps. After installing Siemens Deka 72lb 2.5 ohm units, I can get up to around 5 amps. These injectors are quite good, they can hold a 1.5 ms pulse width meaning I can still get a nice idle and run some pretty big power, the bosch greens were maxing out.

As far as the misfire, turns out the cosworth YB is very particular about injector end angle. Tweaking this sorted it out.
Reply | Threaded
Open this post in threaded view
|

Re: Can't get enough amperage with P&H injectors

Posts
Administrator
Hi mk1,

Must have missed your original post over the weekend. Sorry.

Glad to hear that you got everything sorted out.

If you get a chance please send some pix of your project to info@pe-ltd.com.

Thanks!
Thanks for posting,
PE Support
(513) 777-5233
Reply | Threaded
Open this post in threaded view
|

Re: Can't get enough amperage with P&H injectors

original posts
In reply to this post by original posts


Happy New Year!